![]() |
UltraGrid
UltraGrid Low-Latency High-Resolution Transmission System
|
#include <cstdint>

Go to the source code of this file.
Macros | |
| #define | BUFNUM_BITS 22U |
| #define | PT_AUDIO 21 |
| #define | PT_AUDIO_HAS_FEC(pt) |
| RFC 2550 hdr for audio - 16b MBZ, 16b Frag_off. | |
| #define | PT_AUDIO_IS_ENCRYPTED(pt) |
| #define | PT_AUDIO_RS 35 |
| #define | PT_DynRTP_Type96 96 /* usually H.264 */ |
| #define | PT_DynRTP_Type97 97 /* mU-law stereo amongst others */ |
| #define | PT_ENCRYPT_AUDIO 25 |
| #define | PT_ENCRYPT_AUDIO_RS 36 |
| #define | PT_ENCRYPT_VIDEO 24 |
| #define | PT_ENCRYPT_VIDEO_LDGM 29 |
| #define | PT_ENCRYPT_VIDEO_RS 30 |
| #define | PT_IS_AUDIO(pt) |
| #define | PT_ITU_T_G711_PCMA 8 /* A-law std */ |
| #define | PT_ITU_T_G711_PCMU 0 /* mU-law std */ |
| #define | PT_JPEG 26 /* standard, RFC 2435 (assigned in RFC 3551) */ |
| #define | PT_MPA 14 |
| #define | PT_Unassign_Type95 95 /* reserved for future, backward compatible use with UG (metadata etc.) */ |
| #define | PT_VIDEO 20 |
| #define | PT_VIDEO_HAS_FEC(pt) |
| #define | PT_VIDEO_IS_ENCRYPTED(pt) |
| #define | PT_VIDEO_LDGM 22 |
| #define | PT_VIDEO_RS 27 |
Typedefs | |
| typedef uint32_t | audio_payload_hdr_t[5] |
| typedef uint32_t | crypto_payload_hdr_t[1] |
| typedef uint32_t | fec_payload_hdr_t[5] |
| typedef uint32_t | mpa_hdr_t |
| typedef uint32_t | video_payload_hdr_t[6] |
Enumerations | |
| enum | { FPS_MAX = 1024 } |
| #define BUFNUM_BITS 22U |
Definition at line 171 of file rtp_types.h.
Referenced by decode_audio_frame(), and state_audio_decoder_summary::update().
| #define PT_AUDIO 21 |
Definition at line 67 of file rtp_types.h.
Referenced by decode_yuri_frame(), and fec::pt_from_fec_type().
| #define PT_AUDIO_HAS_FEC | ( | pt | ) |
RFC 2550 hdr for audio - 16b MBZ, 16b Frag_off.
Definition at line 165 of file rtp_types.h.
Referenced by decode_audio_frame().
| #define PT_AUDIO_IS_ENCRYPTED | ( | pt | ) |
Definition at line 166 of file rtp_types.h.
Referenced by decode_audio_frame().
| #define PT_AUDIO_RS 35 |
Definition at line 75 of file rtp_types.h.
Referenced by fec::pt_from_fec_type().
| #define PT_DynRTP_Type96 96 /* usually H.264 */ |
Definition at line 78 of file rtp_types.h.
Referenced by get_video_rtp_pt_rtpmap(), and tx_send_h264().
| #define PT_DynRTP_Type97 97 /* mU-law stereo amongst others */ |
Definition at line 79 of file rtp_types.h.
Referenced by audio_tx_send_standard(), and get_audio_rtp_pt_rtpmap().
| #define PT_ENCRYPT_AUDIO 25 |
Definition at line 70 of file rtp_types.h.
Referenced by fec::pt_from_fec_type().
| #define PT_ENCRYPT_AUDIO_RS 36 |
Definition at line 76 of file rtp_types.h.
Referenced by fec::pt_from_fec_type().
| #define PT_ENCRYPT_VIDEO 24 |
Definition at line 69 of file rtp_types.h.
Referenced by decode_video_frame(), fec::fec_type_from_pt(), and fec::pt_from_fec_type().
| #define PT_ENCRYPT_VIDEO_LDGM 29 |
Definition at line 73 of file rtp_types.h.
Referenced by decode_video_frame(), fec::fec_type_from_pt(), and fec::pt_from_fec_type().
| #define PT_ENCRYPT_VIDEO_RS 30 |
Definition at line 74 of file rtp_types.h.
Referenced by decode_video_frame(), fec::fec_type_from_pt(), and fec::pt_from_fec_type().
| #define PT_IS_AUDIO | ( | pt | ) |
Definition at line 167 of file rtp_types.h.
Referenced by decode_audio_frame().
| #define PT_ITU_T_G711_PCMA 8 /* A-law std */ |
Definition at line 64 of file rtp_types.h.
Referenced by audio_tx_send_standard(), and get_audio_rtp_pt_rtpmap().
| #define PT_ITU_T_G711_PCMU 0 /* mU-law std */ |
Definition at line 63 of file rtp_types.h.
Referenced by audio_tx_send_standard(), and get_audio_rtp_pt_rtpmap().
| #define PT_JPEG 26 /* standard, RFC 2435 (assigned in RFC 3551) */ |
Definition at line 71 of file rtp_types.h.
Referenced by get_video_codec_from_pt_rtpmap(), get_video_rtp_pt_rtpmap(), and tx_send_jpeg().
| #define PT_MPA 14 |
Definition at line 65 of file rtp_types.h.
Referenced by audio_tx_send_standard(), and get_audio_rtp_pt_rtpmap().
| #define PT_Unassign_Type95 95 /* reserved for future, backward compatible use with UG (metadata etc.) */ |
Definition at line 77 of file rtp_types.h.
Referenced by decode_audio_frame(), and decode_video_frame().
| #define PT_VIDEO 20 |
Definition at line 66 of file rtp_types.h.
Referenced by decode_video_frame(), decode_yuri_frame(), fec::fec_type_from_pt(), and fec::pt_from_fec_type().
| #define PT_VIDEO_HAS_FEC | ( | pt | ) |
Definition at line 168 of file rtp_types.h.
Referenced by decode_video_frame().
| #define PT_VIDEO_IS_ENCRYPTED | ( | pt | ) |
| #define PT_VIDEO_LDGM 22 |
Definition at line 68 of file rtp_types.h.
Referenced by decode_video_frame(), fec::fec_type_from_pt(), and fec::pt_from_fec_type().
| #define PT_VIDEO_RS 27 |
Definition at line 72 of file rtp_types.h.
Referenced by decode_video_frame(), fec::fec_type_from_pt(), and fec::pt_from_fec_type().
| typedef uint32_t audio_payload_hdr_t[5] |
Definition at line 129 of file rtp_types.h.
| typedef uint32_t crypto_payload_hdr_t[1] |
Definition at line 161 of file rtp_types.h.
| typedef uint32_t fec_payload_hdr_t[5] |
Definition at line 152 of file rtp_types.h.
| typedef uint32_t mpa_hdr_t |
Definition at line 163 of file rtp_types.h.
| typedef uint32_t video_payload_hdr_t[6] |
Definition at line 107 of file rtp_types.h.
| anonymous enum |
| Enumerator | |
|---|---|
| FPS_MAX | given by UG RTP payload header |
Definition at line 173 of file rtp_types.h.